Click here for Toll-Free Service for your business starting at $2.00 per month

Main Menu

Can't delete files

Started by looie, May 11, 2007, 09:32:52 PM

Previous topic - Next topic



I can't delete a folder on my website, because apparently I don't have the right privileges. I've tried SmartFTP which I usually use, but it didn't work, so I tried the online file manager and that wouldn't let me delete them either.

I get the following error "Warning: unlink(/fpgs/fpgshttpd/looie/chat/i18n/fr_FR/admin.php) [function.unlink]: Permission denied in /home/admin/ on line 22

Warning: rmdir(/fpgs/fpgshttpd/looie/chat/i18n/fr_FR/) [function.rmdir]: Permission denied in /home/admin/ on line 28

Warning: rmdir(/fpgs/fpgshttpd/looie/chat/i18n/) [function.rmdir]: Directory not empty in /home/admin/ on line 28
Deleting of folder failed.

This might be caused by insufficient permissions."

The folder permissions are set to 755 - 777 and 0 also don't work.

I don't know what it is.


Quote from another post:

The "Owner" column in net2ftp basically says the owner of the file. Any file marked "501" is a user's file. Almost all of these files can be edited (the main exception being .ftpquota). Any file marked "48" is a PHP created file, and you'd have to use php to change it.


I opened fr_FR/admin.php and went to line 22 and it was empty, so I didn't know what to do. Wouldn't matter anyway, I can't replace the files on the server.


I have updated the ownership of all files within your account.  You should now be able to modify them.

When files are created by PHP scripts, they must also be modified or removed by PHP scripts as well (or we can chown the files for you)

Thank you, Admin