LVCS.NET offers low cost domain registration services.

Main Menu

Service Temporarily Unavailable

Started by Jess_Wundring, October 17, 2006, 02:34:58 AM

Previous topic - Next topic


I loaded wordpress 2.0 yesterday and it worked fine for several hours and then, poof!
I started (and am continuing) to get this message 90% of the time:

Service Temporarily Unavailable
The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later.
Apache/2.0.54 (Fedora) Server at Port 80

Any clue as to what's going on or how I might debug? There's nothing unusual about the installation, that I know of. It has a standard "approved" theme that I downloaded from the Wordpress site and one plug-in. I dropped a database and created a new one with another name before starting the install.

I was screwing around with the config/layout for awhile. The last thing, that I can think of that I did was put an .htaccess file in the blog's home directory. Could this be causing it to bog down?
Also, images don't seem to be showing up on the blog site anymore.

<a short while later>

Okay, this may be a red herring but....
I've tried renaming .htaccess to something innocuous and now it appears that I can get to the main blog site consistently (heh, 3 times in as many minutes, anyway), but none of the associated "blog pages" are reachable now (generates 404 errors)

Thanks in advance for any suggestions you might have...


Not sure about the service unavailable errors (I randomly get them on my site, but refreshing usually takes care of it). I do know why you're getting 404's now though. WordPress uses the .htaccess file to rewrite URL's like to (or something like that anyway). Therefore without the .htaccess file, those directories don't actually exist, so there's the explanation. Good luck tracking down the other problem :)


Thanks, brainiac. I re-enabled the .htaccess file and refreshed a few times and what do you know....the 503 error is back.


This is so odd. Could the problem be that the .htaccess exists a few (.\1\2\.htaccess) levels down from my root?

Perhaps there's a problem with the contents of my .htaccess?

---------- snip ---------------

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /blog/homeless/
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /blog/homeless/index.php [L]

# END WordPress


It's ok to have an htaccess file anywhere in the directory structure, so that's not the problem. I'm certainly no expert at rewrite rules but I don't see anything wrong with those, except that I've never seen <IfModule mod_rewrite.c> or </IfModule> in an htaccess file before. You might try commenting out those lines with a # and seeing if that makes a difference. Otherwise you'll have to wait until somebody who knows more about htaccess files than I do, sorry.


Most likely your .htaccess mod_rewrite rules are incorrectly redirecting the page in a loop.

Thank you, Admin


Okay, Thanks. I've found that as long as I leave .htaccess empty, it seems to work.  If I let Wordpress modify it though, it doesn't work....I'll let the WordPress folks know that v2.0 has a bug.


Ah, actually its a well-documented bug.

Anybody coming across this post (looking for keywords of .htaccess Wordpress blog perhaps?) in search of similar problems, check this out: