FreePgs.com Forum
September 22, 2021, 05:19:46 PM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News: Donate to FreePgs.
 
   Home   Help Search Login Register  
Pages: 1 [2]   Go Down
  Print  
Author Topic: PHP mail() problems  (Read 25893 times)
webzone (archived)
Official Technical Support
Verified Account
Hero Member
*

Karma: +0/-0
Offline Offline

Posts: 508

Archived Account

Blog entries (0)

View Profile
« Reply #15 on: March 29, 2006, 06:40:32 PM »

The mail function is still enabled on the main server.

It would probably be a good idea to move all your stuff anyway to the main server (because it is more flexible and up-to-date).
Logged
opmail
Non-Verified Account
Newbie
*

Karma: +0/-0
Offline Offline

Posts: 12

Blog entries (0)

View Profile
« Reply #16 on: March 30, 2006, 12:57:37 AM »

Thanks for the info... My domain '5tudio.co.uk' is on the Plesk server I believe (atleast I login to Plesk to administrate/ftp etc)...
What is the main server and how would I move my stuff there???

Do I need to request anything be changed with FreePGS???

THanks again for the help.. Smiley
Logged
FreePgs.com Forum
« Reply #16 on: March 30, 2006, 12:57:37 AM »

 Logged
Ben
FreePgs Tech Support
Technical Support
Sr. Member
*****

Karma: +12/-0
Offline Offline

Posts: 344

Blog entries (0)

View Profile WWW
« Reply #17 on: March 30, 2006, 03:59:37 AM »

The main server (http://system.freepgs.com) should be the one you registered with, and you would have been moved form there to Plesk by a request.

Just login to your Plesk account, download all the files and databases, and upload them to the main server. Then send a contact form request for your domains to be moved from Plesk to the main server, and for any Cron tasks you need moved. You -may- have to change nameservers on the domains for them to be moved, I'm not sure if Plesk uses the same nameservers as the main server does.
Logged

webzone (archived)
Official Technical Support
Verified Account
Hero Member
*

Karma: +0/-0
Offline Offline

Posts: 508

Archived Account

Blog entries (0)

View Profile
« Reply #18 on: March 30, 2006, 05:48:44 PM »

Quote
You -may- have to change nameservers on the domains for them to be moved, I'm not sure if Plesk uses the same nameservers as the main server does

Plesk and the main server use different nameservers and IP addresses, so the change will be necessary.
Logged
FreePgs.com Forum
« Reply #18 on: March 30, 2006, 05:48:44 PM »

 Logged
c
Non-Verified Account
Newbie
*

Karma: +0/-0
Offline Offline

Posts: 7

Blog entries (0)

View Profile
« Reply #19 on: April 02, 2006, 05:12:35 AM »

Today Perl is deactivated and instead of executing the scripts I see their source on the screen!
Logged
webzone (archived)
Official Technical Support
Verified Account
Hero Member
*

Karma: +0/-0
Offline Offline

Posts: 508

Archived Account

Blog entries (0)

View Profile
« Reply #20 on: April 02, 2006, 05:28:03 AM »

Quote
Today Perl is deactivated and instead of executing the scripts I see their source on the screen!

Perl was deactivated a few days ago.
« Last Edit: April 12, 2006, 07:18:10 PM by webzone » Logged
bookish
Verified Account
Jr. Member
*

Karma: +0/-0
Offline Offline

Posts: 48

Blog entries (1)

View Profile
« Reply #21 on: April 02, 2006, 11:25:04 AM »

I have been testing a FormMail script on my PC using the WAMP5 server:

http://www.wampserver.com/en/

http://www.stadtaus.com/en/php_scripts/formmail_script/

I need to set up the referring server details to use it on FreePgs:

$referring_server = 'www.example.com, example.com, 192.0.34.166';

For a FreePgs account is the IP address 64.193.110.130 or 64.193.110.132 ?
Logged
Ben
FreePgs Tech Support
Technical Support
Sr. Member
*****

Karma: +12/-0
Offline Offline

Posts: 344

Blog entries (0)

View Profile WWW
« Reply #22 on: April 02, 2006, 02:35:22 PM »

"64.193.110.130" should be the working one. The other one leads to an unknown domain error for me.

As webzone said, perl was deactivated, if you haven't already just request it be re-enabled on your account.
Logged

bookish
Verified Account
Jr. Member
*

Karma: +0/-0
Offline Offline

Posts: 48

Blog entries (1)

View Profile
« Reply #23 on: April 02, 2006, 04:45:55 PM »

Thanks Ben! The script I'm trying out uses PHP.
Logged
sixthcrusifix
Sage
Verified Account
Sr. Member
*

Karma: +0/-3
Offline Offline

Posts: 445


http://sixthcrusifix.com/home/

Blog entries (0)

View Profile WWW
« Reply #24 on: April 07, 2006, 07:19:32 AM »

I have a suggestion:
Instead of:

Code:
mail($to, $subject, $body, $headers);

echo("finished");


do this:

Code:
if( mail($to, $subject, $body, $headers) ){

echo("finished");

}else{

echo("ERROR IN SENDING EMAIL");

}



That way you will know when there's a problem with the mail function, instead of just always getting  a generic success message, you'll get an error message for failure and a success message for success Cheesy
Logged

Visite me website at http://www.sixthcrusifix.com
possum
Verified Account
Jr. Member
*

Karma: +2/-0
Offline Offline

Posts: 26

Blog entries (0)

View Profile
« Reply #25 on: April 08, 2006, 02:34:22 PM »

Has the mail function been disabled ??
Logged
webzone (archived)
Official Technical Support
Verified Account
Hero Member
*

Karma: +0/-0
Offline Offline

Posts: 508

Archived Account

Blog entries (0)

View Profile
« Reply #26 on: April 08, 2006, 02:57:53 PM »

Quote
Has the mail function been disabled ??

Not on the main server (phpinfo). I don't know about Plesk.
Logged
possum
Verified Account
Jr. Member
*

Karma: +2/-0
Offline Offline

Posts: 26

Blog entries (0)

View Profile
« Reply #27 on: April 08, 2006, 03:27:02 PM »


Configuration: ANJEL 0.6.1- (Joomla! )
sendmail path /usr/sbin/sendm2


xxxx@xxxx.com-> Message could not be sent.
Mailer error: Language string failed to load: execute/usr/sbin/sendm2

or

xxxx@xxxx.com-> Message could not be sent.
Mailer error: Language string failed to load: execute/usr/sbin/sendmail

Logged
protegechris
Non-Verified Account
Newbie
*

Karma: +0/-0
Offline Offline

Posts: 6

Blog entries (0)

View Profile
« Reply #28 on: April 10, 2006, 03:31:55 PM »

It's disabled right now, has been since last night at least. If you're able to use SMTP, that still works for me.
Logged
webzone (archived)
Official Technical Support
Verified Account
Hero Member
*

Karma: +0/-0
Offline Offline

Posts: 508

Archived Account

Blog entries (0)

View Profile
« Reply #29 on: April 10, 2006, 03:42:23 PM »

It might be disabled on Plesk, but on the Freepgs server it works fine.
Logged
Pages: 1 [2]   Go Up
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!