Click here for Toll-Free Service for your business starting at $2.00 per month

Main Menu

MySQL and Wordpress and heeeellppp

Started by manth, January 02, 2006, 03:54:44 PM

Previous topic - Next topic


okay.  a friend of mine reccommended wordpress to me to use for my website.  and i have been trying to install it for hours now.  i have no clue what i am doing.

i created a database.  installation instructions from wordpress say "if a database relating to wordpress does not already exist in the database dropdown menu on the left, create one"  but all i see is to create a table, and how many fields.  then, it tells you to edit privileges, and to create a user.  but i thought, in creating the database itself, i already created a user?  but it says i have no privileges and i have no clue how to change them.

i've tried entering in my database, my username and my password that i created for the database itself and running the install process but instead all i get are error messages saying i didn't edit the config.php when i already did.

i am so confused.  please someone explain to me what i'm doing wrong.  it's probably something stupid, but i desperately need some help.

webzone (archived)

Let's try starting over. (I assume you"re not using Plesk).

1. Go to the View Databases section of your Freepgs Control Panel by clicking here. Do you see your database? If yes, make sure you remember the credentials (username and password). If you don't see the database, you'll need to create one by clicking here.

2. Erase your whole WordPress directory in the file manager or in your FTP client. Then, upload the original files you downloaded from without any modification (not even to wp-config.php).

3. Then go to
For instance, in my case, it would be something like

4. Fill in the form with the settings you remember from step 1.

5. Then go to
For instance, in my case, it would be something like

6. Follow the instructions provided by the setup wizard and you are done!


I don't suppose by any chance your database name is "data"? If it is I would recommend reading

webzone (archived)

QuoteI don't suppose by any chance your database name is "data"?

I'd doubt about it. The problem "manth" describes looks to be in the setup process, which means that the tables would not be created.


Yeah true, just looked like too much of a coincidence to me lol.


Hi, Webzone. I just have the same problem with Manth. I have tried your solution (thanks!). However, in the step 3 , when I  went to
(I suppose it should be, it just said: "Sorry, I can't write to the directory. You'll have to either change the permissions on your WordPress directory or create your wp-config.php manually."
I tried both again (as you know, I have tried the second for dozens of times), but in total vain. I don't know why.
Is it that I have to download 4xxM size Plesk? It's another new thing for me. So please help.


I changed the DB-Host in the wp-config to mysql5, and the problem is finally solved.