Click here for Toll-Free Service for your business starting at $2.00 per month

Main Menu

Online File Manager Not Working (Intermittent)

Started by Kitsuta, April 28, 2007, 05:36:32 PM

Previous topic - Next topic


This is an intermittent problem I've been experiencing: while it will let me edit and save my files, the Online File Manager doesn't actually UPDATE the files, at least not for a prohibitive time.  Testing anything specific about the problem has been difficult because it is intermittent, but I'm fairly sure that none of the changes I make are updated until some time later(the file manager decides to start working again).

I've never experienced this problem before the PHP update; although I didn't start experiencing the issue until a couple of days ago, I'd only changed my files once between the 26th and a couple of days ago when I first encountered the problem, so it may be related.

It might also be important to note that even when I delete files it does not register.

This makes debugging very difficult, so any help is appreciated.  I'd be happy to upgrade the account to a better plan if it'll solve the issue.  Thanks!  ;D


Changes are processed in real time.  I just tested this to be sure it was still happening.

Most likely your ISP uses some type of Proxy or Cache server or your browser is caching the previous content.

Are the changes showing from the File Manager itself if you open the file back up?  (If so, the changes have indeed occurred.)

If you have multiple domain entries associated to your account (i.e. and - you can try the alternate domain and see if the changes are shown.  If they are, your problem is either that your provider uses a Cache server that is not refreshing properly -OR- your browser itself is not refreshing the page properly.

Please try to hold SHIFT and click REFRESH and see if the problem persists (this forces a hard refresh via your browser in most cases)

Thank you, Admin


Hmm.. I thought it might be my cache too, so I used Ctrl+R(which if I recall correctly should force a hard refresh).

My site has only one domain name associated with it, but I'll try Shift+F5 next time I experience the problem.  I'll let you know if that fixes it.  Thanks!


Ctrl+F5 should also work in most browsers.  Some worked with the SHIFT+Refresh button approach.

Thank you, Admin


Okay.  It didn't work when I tried the Shift+Refresh.

Like I said, the problem's hard to test, but it seems to be a problem only when editing the .js file I use.  I just edited another file and it worked, but the page that uses the .js file is still not updated, regardless of how many times I refresh it.  It's pretty bizarre.

And when I cleared my cache manually it worked.  Perhaps it was just a problem with the browser's cache and now it's fixed... I certainly hope so.  I'll let you know if it comes up again and clearing the cache manually doesn't work.  Thanks for your help!


The same problem used to happen with Flash (.swf) files as well (the browser would always use the cached version even during a hard refresh)  Not sure if that was ever fixed as I no longer use flash-based navigation menus on pages.

If the problem persists, you may want to include the .js file reference with an include and update the file name each time it is changed.  (The browser will then reload it since the filename is different)

Thank you, Admin