Click here for Toll-Free Service for your business starting at $2.00 per month

Main Menu

files with owner 48 / permission 755

Started by nospam100, January 09, 2007, 08:07:25 AM

Previous topic - Next topic



1. I've got a whole bunch of files and folders whose owner appears to be 48 and permission is 755 (my user's owner ID is 501). I'm guessing they were created by some scripts that I tried and now I can't delete these files anymore. How can I remove them?

2. I am trying to install a script that requires a large number of files to be chmod'd 777 during installation. Is it possible to get SSH access? I could handle them much better that way.



1) You can request files to be chown'd via the Contact Form

2) We do not provide SSH access at this time.

Thank you, Admin


First of all, the owner 48 is a group made by the admin to prevent any other modifications made by external applications outside the server. So you do not have to worry about the files, you can also request as what the admin says.

*just correct me if im wrong*


Thanks for the advice.

Actually I do have to worry since the files that I'm talking about are locate INSIDE my folders, thus I cannot remove my own folders because I can't empty them, so for now I just moved the folders altogether to a temp directory.

Also I've just uploaded another package via ftp and many of the files seem to have been randomly chown'd with user 48 during or right after the ftp transfer. Now the upgrade script of the package that I just installed won't work because it cannot modify some of them.

So if it is indeed related with some administrative thing then there's something wrong with the implementation.

I could (and will) of course follow the admin's advice, but I'm afraid that something needs to be checked in order to prevent this from reoccurring.


The best course of action (probably) to take, is to have the php script set the chmod on the files to something that allows you access (is 0775 enough or does it need to be 0777?). If the script can't access uploaded files it might be the same problem in reverse, try chmodding the files the script needs to access via ftp.


True, I actually managed to change them all to 777 by using the online ftp filemanager and then I was able to delete them via ftp.

It seems to me that user '48' is actually 'nobody', because I'm sure those files were created by the php scripts.

Anyways, problem solved, lesson learned.



Same problem here.

A gallery component and images uploaded using Joomla are all set to user 48.

Any further image uploads don't work because it cannot create a directory, I guess because I am not the 'owner'.

Have reported it to Support.