LVCS.NET offers low cost domain registration services.

Main Menu

Joomla! TROUBLES (mmkay?)

Started by nerds, July 18, 2006, 07:10:51 AM

Previous topic - Next topic


I'm trying to install Joomla! and I can't even start the installation process. I have been trying every thing possible, can't figure it out. :( I guess I'm stupid. Sure it's something really simple. Please help! (By the way, any successful attempts to have a Joomla! based web-site on Anybody? ::))

What I did was:
- Enabled PHP
- Created MySQL database (which I haven't used yet, since I can't even get to that point)
- Uploaded all the files through FTP to root folder.
- Changed all the permissions to 777.
- Attempted to execute index.php through browser...

404 :o

Mmmkay... I read some more on htaccess.txt and that kinda stuff. Started experimenting with htaaccess.txt (uncommented "Options" line, than even erased it at all - no luck :-\)
And the funniest thing is, that before it would show directory listing, but (i guess as soon as you upload stupid htaccess.txt file there) now just goes 404. ???
Please, be nice ppl and help me out. Thanks. Try not to skip anything, even if it "comes without saying" - I'm inexperienced with PHP, CMS and things like that. Trying to learn, you know... So please don't be too scientific.


Plus, you know, provided that CMS usage grows, it'd be nice to have some kind of how-to guide on Joomla! installation on this server, so this topic is not as lame as you think - might be useful for other newbies later. ;)


Never used it before. Did you read the Readme? Perhaps try reuploading index.php? Maybe you need to install it first before you can view index.php? Is there an install.php file or install directory?



OK I got it to work  ;D (for a couple of minutes actually) ???
I did install it. Allthough after i did it it still won't work (but that's a different issue).
What happened was - it won't let me log on as admin, or anything. I'm damn sure about the password, cause it was a really simple one and I set it literally 4 seconds before it failed to work. :o Might be some other reason. I'll RE-INSTALL everything and we'll see (I wan't it in a different folder anyway).

.htaccess.txt file kinda looked redundant. Fron all the 3 lines in there none seemed to apply to me and readme said uncomment it.  ???

What I really don't like is that pre-instalation kinda self-diagnose tool said that it's gonna have session saving error It was mentioned on this forum before and people said they ignored it and it worked fine.

In my case it didn't work fine at all :-\ :-\ :-\ I'll try over again.


The problem seems to be with the temp sessions:

Session save path      /var/lib/php/session, Unwriteable

It was discussed here:

But no solution was ever found. Except for "I ignored it and it worked fine". :-X Well, I ignored it too and it DIDN'T work fine at all. :-[


I am very familiar with Joomla!.  I use it on my site.  If you would like some help add me to your msn ( or aim (LegendPro AIM) and I will be glad to assist you with your problems.


Here is a quick explanation of the setup process in case I don't get to talk to you online.

1) Upload all the files that came with the Joomla! Package.
2) Go to the directory that you uploaded the files to and you will see that it requests you to change some permissions.
3) Make sure you change those permissions to 777 and then there are also 2 other things in red that you need to fix.
4) In order to fix those issues create an .htaccess file with the following lines:

php_flag register_globals off
php_flag magic_quotes_gpc on

(Note: Do not use the .htaccess file that Joomla! has provided, create your own.)

5) You do not need to worry about the session save path (it will work without touching any of that).  Also do not change the permissions on the config file until the very end (also don't rename the configuration.php-dist to configuration.php yet).
6) Proceed with the installation process and fill in the required forms such as your MySQL database username and password, ect...
7) After the database step you will see the final setup page that has the configuration information.  Copy all of the configuration information and create your own configuration.php file and paste it in there.
8) Upload the new configuration.php and CHMOD it to 777.  You can also delete the installation directory.

You should be able to do everything from there.



THANK YOU Legendpro for help and support! :D

Nice to know that there are people with operational web-sites using Joomla! on here. ;D

I already managed to do everything myself and I'll explain what was wrong (not because I want everybody to know what kind of idiot I am, but for a more sacred purpose - to share the knowledge):

1) Make sure that Joomla! package you have downloaded is a normal standalone package, not a bunch of updates to upgrade, for example from Joomla 1.0.1 to 1.0.10
Your pack should be called something like "Joomla_1.0.8-Stable-Full_Package".

Yes, I was unattentive enough to download a bunch of updates instead of full_package - no wonder when I tried to install it it was looking for "installation" folder! ::)

2)I followed installation guide through and actually installed everything. YES DISREGARD THE TEMP SESSIONS MESSAGE - it's all bullsh**, everything works fine. But then, I COULD NOT LOG IN!!!
The password was right and everything. Instead it showed like 200 different PHP errors and still wasn't logging me.

Now the solution to that was turning of the firewall - as random as it sounds. Switch the damn firewall OFF, or you never gonna log in! :o

Having done so, so far, I'm o.k. It works.

When there's gonna be more pain (I'm sure there will be) I'll continue this thread.
Hope this will be useful for ppl.
Mmmkay. 8)


By firewall, I presume you mean a software firewall on your system?

I am having log in difficulties, it worked fine last night, I didn't change the user or password, and all of a sudden today nothing I do is working, it keeps saying incorrect username, incorrect password...

fixed it!


Did all of the steps and there is still a slight problem. The problem is in the poll module for me and it says:

Parse error: parse error, unexpected T_STRING in /var/www/vhosts/ on line 1

This leads me to believe the error is on line one... however al lthat is on line one is "<?php" haha

If anyone can fix this thanks, if noone can figure it out, no big, I wont have a poll lol :o


Quote from: shortygeorge on July 26, 2006, 06:14:03 PM
By firewall, I presume you mean a software firewall on your system?

Yeah, exactly. On my computer. It's weird to me that it would have such an effect, but since I got that solution from the Internet (after like 5 hours of searching and trying), it's a common issue. Nevertheless, the 1st guy to find it should get an award, cause I imagine he tryed EVERYthing, before locating the problem. I'm not that patient and would have killed myself by that time.  ;D