Quote from: namhuy on April 20, 2014, 09:24:07 AMWhile this can be done easily it would look very suspicious and unprofessional to do this. The reason is anyone can easily open a gmail account and send messages claiming to have your account banned for whatever and asking for your username and password. Believe me this happens more often then you think and people fall for it all the time.
you can always setup smtp with mandrill or google/yahoo smtp
Quote from: admin on April 20, 2014, 10:14:21 PMThis is all very sound advice and disabling mail globally and requiring users to ask to have the function enabled individually would mean only those who truly need it have it enabled. I am developing a php game and just switched on version 5.5 and hope to get it working on that version. As for my script, i try to write my script with security in mind, and as my script doesn't upload and all input is sanitized and checked for validity. I have changed all my passwords recently as a security precaution.
Thank you. We will take these under advisement.
Most likely, we will just stop all mail() functions, but unfortunately, sending of spam is not the only thing that is happening with users and their outdated scripts nor is it just malicious scripts injected on sites, but files being added to phish, etc that themselves are not malicious (in that antivirus, mod_security, rkhunter (which we already use) would catch.
We will go through all users searching for outdated scripts. If a site is found to contain outdated scripts we will be forced to disable all of the users sites permanently without notice. This is unfortunate, but there are too many users that load a script and never use it. Be sure you either keep every script updated or remove scripts you are not using. This includes scripts in /old directories, etc.
In the past, we blocked the mail function and only allowed it upon request. This may need to happen again. (As said above, this would not stop all of the abuse.)
Everyone needs to keep every script they use up to date. They need to be using the highest PHP version their scripts will allow. We will be removing 5.2/5.3 from all servers in the near future. If your scripts do not run with PHP 5.4 or later, it is time to find something else to use.
Due to all of the breaches of late, be sure you are changing all passwords regularly. Especially control panel, FTP, and mail account passwords, but it is also a good idea to change database passwords as well.
EDIT: You should also remove PHP versions that have reached EOL(end-of-life) PHP 5.3 EOL Announcement and require the site owners to use the next higher version. If the scripts on the site stops working then the owner will hopefully "wake up" and can either upgrade the script to a newer version, ask the script publisher to support the latest PHP version or move to a different script. I once had a very bad experience with a host that refuses to upgrade past 5.2.17 because:
QuoteNot only is this a security hazard, but it is very bad advice in general. I'll spare the host embarrassment and not mention who it was but, i will say it was a paid host. Surface to say I asked for a refund and used the money to pay for 10 years of freepgs hosting at the then $3 a year annual fee. That was the best well spent money I have payed. .
It will break existing customers scripts.
P.S. Could you please change the Pong Master text next to my name to Aleeious Lead Developer Thanks.