FreePgs.com Forum
June 23, 2017, 09:56:12 AM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News: Donate to FreePgs.
 
   Home   Help Search Login Register  
Pages: [1] 2 3   Go Down
  Print  
Author Topic: Not worth the aggravation  (Read 4744 times)
admin
Administrator
Hero Member
*****

Karma: +29/-2
Offline Offline

Posts: 1560

Blog entries (0)

View Profile
« on: April 16, 2014, 10:33:37 AM »

Running this service is not worth the aggravation.

We have to constantly deal with spammers exploiting users that do not keep their scripts up to date, our servers getting blacklisted, threatened to unplug our servers on a daily basis, etc.  It is an endless cycle at least every week.

For this reason, we are seriously considering shutting this service down.

The next time we find outdated scripts on a users site, spam coming from a users site, or other activities that are against our terms of service or our providers terms of service, we will be cancelling those accounts permanently.  In most cases, the exploits are either due to outdated CMS/forum/blog scripts that allow users to upload files to your site (then use those files to send massive amounts of spam), or by exploited passwords.  It is important that every change ALL of their passwords, including control panel, FTP, mail accounts, etc.

When updating to a new version of WordPress (for example) be sure to check for malicious files that could have been placed there from an exploited version (especially if you are upgrading from a version older than 3.7.1).
Logged
Scorpion Illuminati
Aleeious Lead Developer
Verified Account
Full Member
*

Karma: +2/-0
Offline Offline

Posts: 100

Project Developer

Blog entries (0)

View Profile WWW
« Reply #1 on: April 16, 2014, 10:57:03 AM »

Running this service is not worth the aggravation.

We have to constantly deal with spammers exploiting users that do not keep their scripts up to date, our servers getting blacklisted, threatened to unplug our servers on a daily basis, etc.  It is an endless cycle at least every week.

For this reason, we are seriously considering shutting this service down.

The next time we find outdated scripts on a users site, spam coming from a users site, or other activities that are against our terms of service or our providers terms of service, we will be cancelling those accounts permanently.  In most cases, the exploits are either due to outdated CMS/forum/blog scripts that allow users to upload files to your site (then use those files to send massive amounts of spam), or by exploited passwords.  It is important that every change ALL of their passwords, including control panel, FTP, mail accounts, etc.

When updating to a new version of WordPress (for example) be sure to check for malicious files that could have been placed there from an exploited version (especially if you are upgrading from a version older than 3.7.1).
That would be very unfortinate and unfair to the users who legitamitly use this wonderful service and have paid for a couple of years. It would punish them more then those who are causing harm. As there aren't many hosts with such great services and very low limits, it would mean laginimate users would have to either pay a bigger fee on a different service or migrate to a free host(and we all know whats that like Tongue). Please keep this wonderful service running, many people depend on it. Smiley

Sincerely,

Customer
Logged

Scorpion Illuminati - A retro rhythm game for the sega genesis!
FreePgs.com Forum
« Reply #1 on: April 16, 2014, 10:57:03 AM »

 Logged
admin
Administrator
Hero Member
*****

Karma: +29/-2
Offline Offline

Posts: 1560

Blog entries (0)

View Profile
« Reply #2 on: April 16, 2014, 12:27:52 PM »

I hope it does not have to be shut down, but unfortunately, a small number of users can cause heaps of problems.  Most of the problem users have been eliminated from the other transitions, so hopefully this will improve.

Running this service is not worth the aggravation.

We have to constantly deal with spammers exploiting users that do not keep their scripts up to date, our servers getting blacklisted, threatened to unplug our servers on a daily basis, etc.  It is an endless cycle at least every week.

For this reason, we are seriously considering shutting this service down.

The next time we find outdated scripts on a users site, spam coming from a users site, or other activities that are against our terms of service or our providers terms of service, we will be cancelling those accounts permanently.  In most cases, the exploits are either due to outdated CMS/forum/blog scripts that allow users to upload files to your site (then use those files to send massive amounts of spam), or by exploited passwords.  It is important that every change ALL of their passwords, including control panel, FTP, mail accounts, etc.

When updating to a new version of WordPress (for example) be sure to check for malicious files that could have been placed there from an exploited version (especially if you are upgrading from a version older than 3.7.1).
That would be very unfortinate and unfair to the users who legitamitly use this wonderful service and have paid for a couple of years. It would punish them more then those who are causing harm. As there aren't many hosts with such great services and very low limits, it would mean laginimate users would have to either pay a bigger fee on a different service or migrate to a free host(and we all know whats that like Tongue). Please keep this wonderful service running, many people depend on it. Smiley

Sincerely,

Customer
Logged
markjay
Verified Account
Full Member
*

Karma: +3/-0
Offline Offline

Posts: 163


Blog entries (0)

View Profile WWW
« Reply #3 on: April 16, 2014, 10:14:39 PM »

FreePgs.com has been one of my favorite hosting service since I hopped-in since way back in 2004. We hope that we can somehow retain legitimate users and eliminate those who abuse this service for spamming.

Cheers for FreePgs.com and for many years to come...
Logged

FreePgs.com Forum
« Reply #3 on: April 16, 2014, 10:14:39 PM »

 Logged
admin
Administrator
Hero Member
*****

Karma: +29/-2
Offline Offline

Posts: 1560

Blog entries (0)

View Profile
« Reply #4 on: April 17, 2014, 09:05:53 PM »

The problem is not with users spamming, but users not keeping their scripts up to date that then allow others to inject files, setup phishing sites, and send massive amounts of spam.
Logged
zen
Verified Account
Jr. Member
*

Karma: +0/-0
Offline Offline

Posts: 34

Blog entries (1)

View Profile
« Reply #5 on: April 18, 2014, 02:29:52 AM »

Users who don't upgrade their script after reminders had been sent are not serious about their site or they just don't care. This show their site are either not important to them or they had an attitude problem. They should be using facebook instead of making website. Should consider suspend them for the first and second time and let them explains why their script is not updated and on the 3rd time they should be kick  out. I think this have been going on for ages something need to be done otherwise these people just don't paid attention to our problem.
Logged
namhuy
Verified Account
Newbie
*

Karma: +0/-0
Offline Offline

Posts: 19

http://namhuy.net

Blog entries (0)

View Profile WWW
« Reply #6 on: April 19, 2014, 12:13:32 PM »

Admin, are you Ed? install rkhunter, chkrootkit, ClamAV, and mod_security. If you can limit sending mail or block it completely.

For wordpress users, I believe there is a plugin to let auto update plugins/theme (not sure auto update wordpress core or not).
Logged

http://namhuy.net Geeky Open Source Linux Tutorials
Scorpion Illuminati
Aleeious Lead Developer
Verified Account
Full Member
*

Karma: +2/-0
Offline Offline

Posts: 100

Project Developer

Blog entries (0)

View Profile WWW
« Reply #7 on: April 20, 2014, 02:36:25 AM »

Admin, are you Ed? install rkhunter, chkrootkit, ClamAV, and mod_security. If you can limit sending mail or block it completely.

For wordpress users, I believe there is a plugin to let auto update plugins/theme (not sure auto update wordpress core or not).
Those are for rootkits and viruses which while useful don't really do much since I suspect many of the scripts sending the spam are normal php scripts that exploit a security hole somewhere down the line or simply scripts that run indefinitely using the mail() function to send a predetermined email message. mod_security seems like  very good answer as well as Suhosin. Limiting emails may pose a problem when the person hosing the site can no longer send password reset instructions or registration info to users.
Logged

Scorpion Illuminati - A retro rhythm game for the sega genesis!
namhuy
Verified Account
Newbie
*

Karma: +0/-0
Offline Offline

Posts: 19

http://namhuy.net

Blog entries (0)

View Profile WWW
« Reply #8 on: April 20, 2014, 05:24:07 AM »

you can always setup smtp with mandrill or google/yahoo smtp
Logged

http://namhuy.net Geeky Open Source Linux Tutorials
admin
Administrator
Hero Member
*****

Karma: +29/-2
Offline Offline

Posts: 1560

Blog entries (0)

View Profile
« Reply #9 on: April 20, 2014, 06:14:21 PM »

Thank you.  We will take these under advisement.

Most likely, we will just stop all mail() functions, but unfortunately, sending of spam is not the only thing that is happening with users and their outdated scripts nor is it just malicious scripts injected on sites, but files being added to phish, etc that themselves are not malicious (in that antivirus, mod_security, rkhunter (which we already use) would catch.

We will go through all users searching for outdated scripts.  If a site is found to contain outdated scripts we will be forced to disable all of the users sites permanently without notice.  This is unfortunate, but there are too many users that load a script and never use it.  Be sure you either keep every script updated or remove scripts you are not using.  This includes scripts in /old directories, etc.

In the past, we blocked the mail function and only allowed it upon request.  This may need to happen again.  (As said above, this would not stop all of the abuse.)

Everyone needs to keep every script they use up to date.  They need to be using the highest PHP version their scripts will allow.  We will be removing 5.2/5.3 from all servers in the near future.  If your scripts do not run with PHP 5.4 or later, it is time to find something else to use.

Due to all of the breaches of late, be sure you are changing all passwords regularly.  Especially control panel, FTP, and mail account passwords, but it is also a good idea to change database passwords as well.
Logged
admin
Administrator
Hero Member
*****

Karma: +29/-2
Offline Offline

Posts: 1560

Blog entries (0)

View Profile
« Reply #10 on: April 20, 2014, 06:51:54 PM »

We will be doing additional scans for outdated WordPress versions on all servers tomorrow at some point.  If your site is found to not be running the latest version, your site will be suspended.

If more than 15 sites are found that contain outdated scripts, we will seriously consider disabling the mail function globally.
Logged
Scorpion Illuminati
Aleeious Lead Developer
Verified Account
Full Member
*

Karma: +2/-0
Offline Offline

Posts: 100

Project Developer

Blog entries (0)

View Profile WWW
« Reply #11 on: April 20, 2014, 10:33:41 PM »

you can always setup smtp with mandrill or google/yahoo smtp
While this can be done easily it would look very suspicious and unprofessional to do this. The reason is anyone can easily open a gmail account and send messages claiming to have your account banned for whatever and asking for your username and password. Believe me this happens more often then you think and people fall for it all the time.

Thank you.  We will take these under advisement.

Most likely, we will just stop all mail() functions, but unfortunately, sending of spam is not the only thing that is happening with users and their outdated scripts nor is it just malicious scripts injected on sites, but files being added to phish, etc that themselves are not malicious (in that antivirus, mod_security, rkhunter (which we already use) would catch.

We will go through all users searching for outdated scripts.  If a site is found to contain outdated scripts we will be forced to disable all of the users sites permanently without notice.  This is unfortunate, but there are too many users that load a script and never use it.  Be sure you either keep every script updated or remove scripts you are not using.  This includes scripts in /old directories, etc.

In the past, we blocked the mail function and only allowed it upon request.  This may need to happen again.  (As said above, this would not stop all of the abuse.)

Everyone needs to keep every script they use up to date.  They need to be using the highest PHP version their scripts will allow.  We will be removing 5.2/5.3 from all servers in the near future.  If your scripts do not run with PHP 5.4 or later, it is time to find something else to use.

Due to all of the breaches of late, be sure you are changing all passwords regularly.  Especially control panel, FTP, and mail account passwords, but it is also a good idea to change database passwords as well.
This is all very sound advice and disabling mail globally and requiring users to ask to have the function enabled individually would mean only those who truly need it have it enabled. I am developing a php game and just switched on version 5.5 and hope to get it working on that version. As for my script, i try to write my script with security in mind, and as my script doesn't upload and all input is sanitized and checked for validity. Tongue I have changed all my passwords recently as a security precaution.

EDIT: You should also remove PHP versions that have reached EOL(end-of-life) PHP 5.3 EOL Announcement and require the site owners to use the next higher version. If the scripts on the site stops working then the owner will hopefully "wake up" and can either upgrade the script to a newer version, ask the script publisher to support the latest PHP version or move to a different script. I once had a very bad experience with a host that refuses to upgrade past 5.2.17 because:
Quote
It will break existing customers scripts.
Not only is this a security hazard, but it is very bad advice in general. I'll spare the host embarrassment and not mention who it was but, i will say it was a paid host. Surface to say I asked for a refund and used the money to pay for 10 years of freepgs hosting at the then $3 a year annual fee. That was the best well spent money I have payed. Tongue.
Sincerely,

Aleeious

P.S. Could you please change the Pong Master text next to my name to Aleeious Lead Developer Thanks.
« Last Edit: April 20, 2014, 11:23:57 PM by Aleeious » Logged

Scorpion Illuminati - A retro rhythm game for the sega genesis!
Scorpion Illuminati
Aleeious Lead Developer
Verified Account
Full Member
*

Karma: +2/-0
Offline Offline

Posts: 100

Project Developer

Blog entries (0)

View Profile WWW
« Reply #12 on: April 21, 2014, 01:54:30 AM »

Not sure why it won't let me edit my original post but, here is a literately 3 minute video on updating your Wordpress installation with just a couple of clicks. Now there is no excuse for why you didn't do it.

Sincerely,

Aleeious

Link - here
Logged

Scorpion Illuminati - A retro rhythm game for the sega genesis!
namhuy
Verified Account
Newbie
*

Karma: +0/-0
Offline Offline

Posts: 19

http://namhuy.net

Blog entries (0)

View Profile WWW
« Reply #13 on: April 21, 2014, 04:57:08 AM »

I didnt realized default php from centos yum is 5.3 x_x I just upgraded to 5.5 using remi/epel repo on my vps just now. centos is too slow to get to packages.

Aleeious, there is an auto update plugin for wordpress, I tried before and It works, you might want to looking into it Smiley
Logged

http://namhuy.net Geeky Open Source Linux Tutorials
Scorpion Illuminati
Aleeious Lead Developer
Verified Account
Full Member
*

Karma: +2/-0
Offline Offline

Posts: 100

Project Developer

Blog entries (0)

View Profile WWW
« Reply #14 on: April 22, 2014, 01:45:49 AM »

I didnt realized default php from centos yum is 5.3 x_x I just upgraded to 5.5 using remi/epel repo on my vps just now. centos is too slow to get to packages.

Aleeious, there is an auto update plugin for wordpress, I tried before and It works, you might want to looking into it Smiley
There is no need to install a plug-in, Wordpress 2.7+ includes it as part of the core software and for reference i currently don't use Wordpress but, have in the past.

Sincerely,

Aleeious
Logged

Scorpion Illuminati - A retro rhythm game for the sega genesis!
Pages: [1] 2 3   Go Up
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!