FreePgs.com Forum
April 29, 2017, 01:35:38 PM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News: Click Here for Toll-Free Service for your business starting at $2.00 per month and 4.5 cents per minute
 
   Home   Help Search Login Register  
Pages: 1 ... 8 9 [10]
 91 
 on: April 23, 2014, 12:28:22 AM 
Started by admin - Last post by admin
We will be removing PHP 5.2.17 from all servers in the near future.

If you have scripts that require these older versions, those scripts will no longer function on our service.

Users that have PHP 5.2.17 selected will be updated to 5.3.28.

When 5.3 is removed, those users will be updated to 5.4.

Please be sure you have selected the highest PHP version that your script will run with.  It is recommended to use PHP 5.4 or 5.5 for all sites.  PHP 5.3 should bed avoided as it is nearing the end of its life.  PHP 5.2 reached end of life more than 2 years ago.

 92 
 on: April 22, 2014, 09:08:37 PM 
Started by admin - Last post by admin

EDIT: You should also remove PHP versions that have reached EOL(end-of-life) PHP 5.3 EOL Announcement and require the site owners to use the next higher version. If the scripts on the site stops working then the owner will hopefully "wake up" and can either upgrade the script to a newer version, ask the script publisher to support the latest PHP version or move to a different script. I once had a very bad experience with a host that refuses to upgrade past 5.2.17 because:

Sorry for the double post.  Our plans are to remove 5.2 and 5.3 once 5.6 is released.  (5.2 may very well be removed before that.  It has only been kept due to compatibility reasons for some users, but honestly it is not worth the risk.)  The problem is that some have 5.2.17 selected that can use a newer version.
True, however they will be running newer versions of PHP that are more secure and compatibility won't maa difference throwing out the whole "5.2.17 for compatibility" issue. As for the others that aren't compatible my last comment still stands.

P.S. Could you please change the Pong Master text next to my name to Aleeious Lead Developer Thanks.

Are you not able to update your title in the forum?  If not, I will do this for you.
Nope, seems when you upgraded the forum you removed the permissions required to self update it. Thanks for updating it.

Sincerely,

Aleeious

I agree with you about older PHP versions, especially 5.2.17.  We will force these to at least 5.3.28 and remove 5.2.17 as a selection.  I have found some users still using 5.2.17 because that is what they were using on the old servers, even though they are running newer scripts.  Once 5.6.x is released, the same thing will be done with 5.3, moving all that have 5.3 set to 5.4.  The choices will be 5.4/5.5/5.6 at that time.

 93 
 on: April 22, 2014, 05:11:21 PM 
Started by admin - Last post by Scorpion Illuminati

EDIT: You should also remove PHP versions that have reached EOL(end-of-life) PHP 5.3 EOL Announcement and require the site owners to use the next higher version. If the scripts on the site stops working then the owner will hopefully "wake up" and can either upgrade the script to a newer version, ask the script publisher to support the latest PHP version or move to a different script. I once had a very bad experience with a host that refuses to upgrade past 5.2.17 because:

Sorry for the double post.  Our plans are to remove 5.2 and 5.3 once 5.6 is released.  (5.2 may very well be removed before that.  It has only been kept due to compatibility reasons for some users, but honestly it is not worth the risk.)  The problem is that some have 5.2.17 selected that can use a newer version.
True, however they will be running newer versions of PHP that are more secure and compatibility won't maa difference throwing out the whole "5.2.17 for compatibility" issue. As for the others that aren't compatible my last comment still stands.

P.S. Could you please change the Pong Master text next to my name to Aleeious Lead Developer Thanks.

Are you not able to update your title in the forum?  If not, I will do this for you.
Nope, seems when you upgraded the forum you removed the permissions required to self update it. Thanks for updating it.

Sincerely,

Aleeious

 94 
 on: April 22, 2014, 12:07:11 PM 
Started by admin - Last post by admin

EDIT: You should also remove PHP versions that have reached EOL(end-of-life) PHP 5.3 EOL Announcement and require the site owners to use the next higher version. If the scripts on the site stops working then the owner will hopefully "wake up" and can either upgrade the script to a newer version, ask the script publisher to support the latest PHP version or move to a different script. I once had a very bad experience with a host that refuses to upgrade past 5.2.17 because:

Sorry for the double post.  Our plans are to remove 5.2 and 5.3 once 5.6 is released.  (5.2 may very well be removed before that.  It has only been kept due to compatibility reasons for some users, but honestly it is not worth the risk.)  The problem is that some have 5.2.17 selected that can use a newer version.

 95 
 on: April 22, 2014, 12:02:07 PM 
Started by admin - Last post by admin
P.S. Could you please change the Pong Master text next to my name to Aleeious Lead Developer Thanks.

Are you not able to update your title in the forum?  If not, I will do this for you.

 96 
 on: April 22, 2014, 01:45:49 AM 
Started by admin - Last post by Scorpion Illuminati
I didnt realized default php from centos yum is 5.3 x_x I just upgraded to 5.5 using remi/epel repo on my vps just now. centos is too slow to get to packages.

Aleeious, there is an auto update plugin for wordpress, I tried before and It works, you might want to looking into it Smiley
There is no need to install a plug-in, Wordpress 2.7+ includes it as part of the core software and for reference i currently don't use Wordpress but, have in the past.

Sincerely,

Aleeious

 97 
 on: April 21, 2014, 04:57:08 AM 
Started by admin - Last post by namhuy
I didnt realized default php from centos yum is 5.3 x_x I just upgraded to 5.5 using remi/epel repo on my vps just now. centos is too slow to get to packages.

Aleeious, there is an auto update plugin for wordpress, I tried before and It works, you might want to looking into it Smiley

 98 
 on: April 21, 2014, 01:54:30 AM 
Started by admin - Last post by Scorpion Illuminati
Not sure why it won't let me edit my original post but, here is a literately 3 minute video on updating your Wordpress installation with just a couple of clicks. Now there is no excuse for why you didn't do it.

Sincerely,

Aleeious

Link - here

 99 
 on: April 20, 2014, 10:33:41 PM 
Started by admin - Last post by Scorpion Illuminati
you can always setup smtp with mandrill or google/yahoo smtp
While this can be done easily it would look very suspicious and unprofessional to do this. The reason is anyone can easily open a gmail account and send messages claiming to have your account banned for whatever and asking for your username and password. Believe me this happens more often then you think and people fall for it all the time.

Thank you.  We will take these under advisement.

Most likely, we will just stop all mail() functions, but unfortunately, sending of spam is not the only thing that is happening with users and their outdated scripts nor is it just malicious scripts injected on sites, but files being added to phish, etc that themselves are not malicious (in that antivirus, mod_security, rkhunter (which we already use) would catch.

We will go through all users searching for outdated scripts.  If a site is found to contain outdated scripts we will be forced to disable all of the users sites permanently without notice.  This is unfortunate, but there are too many users that load a script and never use it.  Be sure you either keep every script updated or remove scripts you are not using.  This includes scripts in /old directories, etc.

In the past, we blocked the mail function and only allowed it upon request.  This may need to happen again.  (As said above, this would not stop all of the abuse.)

Everyone needs to keep every script they use up to date.  They need to be using the highest PHP version their scripts will allow.  We will be removing 5.2/5.3 from all servers in the near future.  If your scripts do not run with PHP 5.4 or later, it is time to find something else to use.

Due to all of the breaches of late, be sure you are changing all passwords regularly.  Especially control panel, FTP, and mail account passwords, but it is also a good idea to change database passwords as well.
This is all very sound advice and disabling mail globally and requiring users to ask to have the function enabled individually would mean only those who truly need it have it enabled. I am developing a php game and just switched on version 5.5 and hope to get it working on that version. As for my script, i try to write my script with security in mind, and as my script doesn't upload and all input is sanitized and checked for validity. Tongue I have changed all my passwords recently as a security precaution.

EDIT: You should also remove PHP versions that have reached EOL(end-of-life) PHP 5.3 EOL Announcement and require the site owners to use the next higher version. If the scripts on the site stops working then the owner will hopefully "wake up" and can either upgrade the script to a newer version, ask the script publisher to support the latest PHP version or move to a different script. I once had a very bad experience with a host that refuses to upgrade past 5.2.17 because:
Quote
It will break existing customers scripts.
Not only is this a security hazard, but it is very bad advice in general. I'll spare the host embarrassment and not mention who it was but, i will say it was a paid host. Surface to say I asked for a refund and used the money to pay for 10 years of freepgs hosting at the then $3 a year annual fee. That was the best well spent money I have payed. Tongue.
Sincerely,

Aleeious

P.S. Could you please change the Pong Master text next to my name to Aleeious Lead Developer Thanks.

 100 
 on: April 20, 2014, 06:51:54 PM 
Started by admin - Last post by admin
We will be doing additional scans for outdated WordPress versions on all servers tomorrow at some point.  If your site is found to not be running the latest version, your site will be suspended.

If more than 15 sites are found that contain outdated scripts, we will seriously consider disabling the mail function globally.

Pages: 1 ... 8 9 [10]
Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!